const regex = /^(?!(?:[01]*11){2})(?!(?:[01]*00){2})(?=[01]*11)[01]*00[01]*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!(?:[01]*11){2})(?!(?:[01]*00){2})(?=[01]*11)[01]*00[01]*$', 'gm')
const str = `0101010011
0011
010101
10
1001011010101010
10
10101
101011
11010100
1001100000010101010101
010000
01000100
110011
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}