re = /^(?!(?:[01]*11){2})(?!(?:[01]*00){2})(?=[01]*11)[01]*00[01]*$/m
str = '0101010011
0011
010101
10
1001011010101010
10
10101
101011
11010100
1001100000010101010101
010000
01000100
110011
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end