using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[\w\.\/]*(?<!\/)(\?.*\=.*)*$";
string input = @"www.google.com
www.google.com/
www.google.com/something
www.google.com/something/
www.google.com/something?a=b
www.google.com/something/?a=b";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}