$re = '/^[\w\.\/]*(?<!\/)(\?.*\=.*)*$/m';
$str = 'www.google.com
www.google.com/
www.google.com/something
www.google.com/something/
www.google.com/something?a=b
www.google.com/something/?a=b';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);