# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^S0\w*(?:-\d+)?\W* 11\b"
test_str = ("V0EQ21309-128 1 1001600535.99N0023642.63E 478409.56662024.7 107.91520748348\n"
"S0EQ21309-128 11 1001600532.60N0023645.31E 478450.26661919.6 0.01520748348\n"
"T0EQ21309-128 1 1 1001600452.10N0023713.63E 478880.66660664.0 0.01520748348\n"
"T0EQ21309-128 1 2 1001600452.35N0023715.00E 478901.96660671.8 0.01520748348\n"
"C0EQ21309-128 111 1001600532.07N0023645.24E 478449.06661903.2 0.01520748348\n"
"C0EQ21309-128 113 1001600532.22N0023646.01E 478461.06661907.6 0.01520748348")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.