re = /^S0\w*(?:-\d+)?\W* 11\b/m
str = 'V0EQ21309-128 1 1001600535.99N0023642.63E 478409.56662024.7 107.91520748348
S0EQ21309-128 11 1001600532.60N0023645.31E 478450.26661919.6 0.01520748348
T0EQ21309-128 1 1 1001600452.10N0023713.63E 478880.66660664.0 0.01520748348
T0EQ21309-128 1 2 1001600452.35N0023715.00E 478901.96660671.8 0.01520748348
C0EQ21309-128 111 1001600532.07N0023645.24E 478449.06661903.2 0.01520748348
C0EQ21309-128 113 1001600532.22N0023646.01E 478461.06661907.6 0.01520748348'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end