const regex = /^[0-4]\d{2}[0-5]$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[0-4]\\d{2}[0-5]$', 'gm')
const str = `0000
1111
4095
4096
4195`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}