$re = '/^[0-4]\d{2}[0-5]$/m';
$str = '0000
1111
4095
4096
4195';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);