package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\bt\w+\b`)
var str = `Now that's the truth and you know it.`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}