$re = '/\bt\w+\b/';
$str = 'Now that\'s the truth and you know it.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);