const regex = new RegExp('(\\w+)=(\\w+)', 'gm')
const str = `{
"request": "START_SIGNATURE",
"request_id": "9876543210",
"user": "{{user}}",
"password": "{{password}}",
"signature": {
"config_id": 12345,
"contract_id": "CompanyID1233456",
"level": [
{
"level_order": 0,
"required_signatories_to_complete_level": 2,
"signatories": [
{
"phone": "+34666666666",
"email": "signatory1@gmail.com",
"name": "Nombre1",
"surname": "Apellido1",
"position_id": "1"
},
{
"phone": "+34677777777",
"email": "signatory2@gmail.com",
"name": "Nombre2",
"surname": "Apellido2",
"upload_files_registered": "Y",
"position_id": "2",
"upload_files": [
{
"name": "Foto DNI",
"optional": "Y"
}
]
}
]
},
{
"level_order": 1,
"required_signatories_to_complete_level": 1,
"signatories": [
{
"phone": "+34688888888",
"email": "signatory3@gmail.com",
"name": "Nombre3",
"surname": "Apellido3",
"position_id": "3"
}
]
}
],
"file": [
{
"filename": "contract.pdf",
"content": "{{base64_file_content}}",
"file_group": "contract_files",
"signature_position": [
{
"signatory_position_id": "1",
"page": "all",
"x": 40.0,
"y": 50.0,
"height": 20,
"width": 30,
"rotation": 0
},
{
"signatory_position_id": "2",
"page": "4",
"x": 80.0,
"y": 50.0,
"height": 20,
"width": 30,
"rotation": 0
},
{
"signatory_position_id": "3",
"page": "last",
"x": 60.0,
"y": 120.0
}
]
}
]
}
}`;
const subst = `"$1":"$2",`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);