import re
regex = re.compile(r"(\w+)=(\w+)", flags=re.MULTILINE)
test_str = ("{\n"
" \"request\": \"START_SIGNATURE\",\n"
" \"request_id\": \"9876543210\",\n"
" \"user\": \"{{user}}\",\n"
" \"password\": \"{{password}}\",\n"
" \"signature\": {\n"
" \"config_id\": 12345,\n"
" \"contract_id\": \"CompanyID1233456\",\n"
" \"level\": [\n"
" {\n"
" \"level_order\": 0,\n"
" \"required_signatories_to_complete_level\": 2,\n"
" \"signatories\": [\n"
" {\n"
" \"phone\": \"+34666666666\",\n"
" \"email\": \"signatory1@gmail.com\",\n"
" \"name\": \"Nombre1\",\n"
" \"surname\": \"Apellido1\",\n"
" \"position_id\": \"1\"\n"
" },\n"
" {\n"
" \"phone\": \"+34677777777\",\n"
" \"email\": \"signatory2@gmail.com\",\n"
" \"name\": \"Nombre2\",\n"
" \"surname\": \"Apellido2\",\n"
" \"upload_files_registered\": \"Y\",\n"
" \"position_id\": \"2\",\n"
" \"upload_files\": [\n"
" {\n"
" \"name\": \"Foto DNI\",\n"
" \"optional\": \"Y\"\n"
" }\n"
" ]\n"
" }\n"
" ]\n"
" },\n"
" {\n"
" \"level_order\": 1,\n"
" \"required_signatories_to_complete_level\": 1,\n"
" \"signatories\": [\n"
" {\n"
" \"phone\": \"+34688888888\",\n"
" \"email\": \"signatory3@gmail.com\",\n"
" \"name\": \"Nombre3\",\n"
" \"surname\": \"Apellido3\",\n"
" \"position_id\": \"3\"\n"
" }\n"
" ]\n"
" }\n"
" ],\n"
" \"file\": [\n"
" {\n"
" \"filename\": \"contract.pdf\",\n"
" \"content\": \"{{base64_file_content}}\",\n"
" \"file_group\": \"contract_files\",\n"
" \"signature_position\": [\n"
" {\n"
" \"signatory_position_id\": \"1\",\n"
" \"page\": \"all\",\n"
" \"x\": 40.0,\n"
" \"y\": 50.0,\n"
" \"height\": 20,\n"
" \"width\": 30,\n"
" \"rotation\": 0\n"
" },\n"
" {\n"
" \"signatory_position_id\": \"2\",\n"
" \"page\": \"4\",\n"
" \"x\": 80.0,\n"
" \"y\": 50.0,\n"
" \"height\": 20,\n"
" \"width\": 30,\n"
" \"rotation\": 0\n"
" },\n"
" {\n"
" \"signatory_position_id\": \"3\",\n"
" \"page\": \"last\",\n"
" \"x\": 60.0,\n"
" \"y\": 120.0\n"
" }\n"
" ]\n"
" }\n"
" ]\n"
" }\n"
"}")
subst = "\"$1\":\"$2\","
result = regex.sub(subst, test_str)
if result:
print(result)