package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^([aA]v\/|[aA]venida)\s?([A-Za-z ]{0,})\,?\s?(\d{0,}|s\/n)\,?\s?\d{0,}[ºª]?\s?[a-zA-Z]?$`)
var str = `calle prueba, 2
calle de la prueba, 5
Avenida de la prueba, 5
Plaza de la prueba, 5
Avenida Higuereta, 4, 7º B
Avenida Escritor Conde Zamora s/n
Avenida Ciudad de Aranjuez 18
Avenida Pintor Sorolla 125 4ºG
Polígono Industrial Aranguren 6
Avenida Gremi Passamaners 24 2º
Avenida Manuel Rodriguez Ayuso, 170
Avenida Illa de Buda 55
C/ Walia, 21
C/Alfonso Pesquera, 6`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}