import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^([aA]v\\/|[aA]venida)\\s?([A-Za-z ]{0,})\\,?\\s?(\\d{0,}|s\\/n)\\,?\\s?\\d{0,}[ºª]?\\s?[a-zA-Z]?$";
final String string = "calle prueba, 2\n"
+ "calle de la prueba, 5\n"
+ "Avenida de la prueba, 5\n"
+ "Plaza de la prueba, 5\n"
+ "Avenida Higuereta, 4, 7º B\n"
+ "Avenida Escritor Conde Zamora s/n\n"
+ "Avenida Ciudad de Aranjuez 18\n"
+ "Avenida Pintor Sorolla 125 4ºG\n"
+ "Polígono Industrial Aranguren 6\n"
+ "Avenida Gremi Passamaners 24 2º\n"
+ "Avenida Manuel Rodriguez Ayuso, 170\n"
+ "Avenida Illa de Buda 55\n"
+ "C/ Walia, 21 \n"
+ "C/Alfonso Pesquera, 6";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}