#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?=[ple]*a[ple]*$)(?=[ape]*l[ape]*$)(?=[apl]*e[apl]*$)[ale]*pp[ale]*$"
Local $sString = "Apple" & @CRLF & _
"ppleA" & @CRLF & _
"APPLE" & @CRLF & _
"apple" & @CRLF & _
"ppale" & @CRLF & _
"" & @CRLF & _
"apaple" & @CRLF & _
"" & @CRLF & _
"foo" & @CRLF & _
"appple" & @CRLF & _
"aple" & @CRLF & _
"bar" & @CRLF & _
"test"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")