re = /^(?=[ple]*a[ple]*$)(?=[ape]*l[ape]*$)(?=[apl]*e[apl]*$)[ale]*pp[ale]*$/mi
str = 'Apple
ppleA
APPLE
apple
ppale
apaple
foo
appple
aple
bar
test'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end