re = /^([a-z-A-Z-0-9._]+)@([a-zA-Z-0-9]+)([.])([a-z-A-Z]+)([.][a-z-A-Z]+)?$/m
str = 'igor.ma222323tos@domini01.com.br'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end