// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^([a-z-A-Z-0-9._]+)@([a-zA-Z-0-9]+)([.])([a-z-A-Z]+)([.][a-z-A-Z]+)?$").unwrap();
let string = "igor.ma222323tos@domini01.com.br";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}