$re = '@(?<=www\.)[^\.]+@m';
$str = 'http://www.google.com
http://www.google.co.jp
http://google.co.jp
http://google.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);