re = /(?<=www\.)[^\.]+/m
str = 'http://www.google.com
http://www.google.co.jp
http://google.co.jp
http://google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end