package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\w*Dog\w*`)
var str = `bla Dog bla Doglets bla bla letsDog bla letsDogbla bla`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}