$re = '/\w*Dog\w*/m';
$str = 'bla Dog bla Doglets bla bla letsDog bla letsDogbla bla';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);