$re = '/[^=\s]+(=<[^<>]+>)\s*[^=\s]+\1/m';
$str = 'from=<test@test.ch> to=<test@test.ch>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);