re = /[^=\s]+(=<[^<>]+>)\s*[^=\s]+\1/m
str = 'from=<test@test.ch> to=<test@test.ch>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end