$re = '/^Guest Introspection|^Trend Micro Deep Security/i';
$str = 'Guest Introspection (4)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);