re = /^Guest Introspection|^Trend Micro Deep Security/i
str = 'Guest Introspection (4)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end