const regex = /(?x) # Free spacing mode, to allow comment and better view
# Matching the first line `i5-2520M` (capture group 1)
([^ ]+\s*)(?=CPU\s*@)
# Matching the first line `2.50GHz` (capture group 2)
|(?<=CPU\s@)(\s*\d+.\d+GHz)
# Matching the `first word` on the second line. (capture group 3)
# The `\s*$` is used to not match empty lines.
|(^[^ ]+)(?!(?:.*CPU\s*@)|\s*$)
# Matching the second line `CPU T2400` (capture group 4)
|(?<=CPU)(\s*[^ ]+\s*)(?=@)
# Matching the second line `1.83GHz` (capture group 5)
|\s*(?<=@)(\s*\d+.\d+GHz)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?x) # Free spacing mode, to allow comment and better view
# Matching the first line `i5-2520M` (capture group 1)
([^ ]+\\s*)(?=CPU\\s*@)
# Matching the first line `2.50GHz` (capture group 2)
|(?<=CPU\\s@)(\\s*\\d+.\\d+GHz)
# Matching the `first word` on the second line. (capture group 3)
# The `\\s*$` is used to not match empty lines.
|(^[^ ]+)(?!(?:.*CPU\\s*@)|\\s*$)
# Matching the second line `CPU T2400` (capture group 4)
|(?<=CPU)(\\s*[^ ]+\\s*)(?=@)
# Matching the second line `1.83GHz` (capture group 5)
|\\s*(?<=@)(\\s*\\d+.\\d+GHz)', 'gm')
const str = `Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz
Genuine Intel(R) CPU T2400 @ 1.83GHz
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}