import re
regex = re.compile((r"(?x) # Free spacing mode, to allow comment and better view\n\n"
r"# Matching the first line `i5-2520M` (capture group 1)\n"
r"([^ ]+\s*)(?=CPU\s*@)\n\n"
r"# Matching the first line `2.50GHz` (capture group 2)\n"
r"|(?<=CPU\s@)(\s*\d+.\d+GHz)\n\n"
r"# Matching the `first word` on the second line. (capture group 3)\n"
r"# The `\s*$` is used to not match empty lines.\n"
r"|(^[^ ]+)(?!(?:.*CPU\s*@)|\s*$) \n\n"
r"# Matching the second line `CPU T2400` (capture group 4)\n"
r"|(?<=CPU)(\s*[^ ]+\s*)(?=@)\n\n"
r"# Matching the second line `1.83GHz` (capture group 5)\n"
r"|\s*(?<=@)(\s*\d+.\d+GHz)"), flags=re.MULTILINE)
test_str = ("Intel(R) Core(TM) i5-2520M CPU @ 2.50GHz\n"
"Genuine Intel(R) CPU T2400 @ 1.83GHz\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")