using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\.)\bbtn\b";
string substitution = @"btn btn-default";
string input = @"btn or .btn ";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}