$re = '/\s{0,3}\d{4}\w{0,1}/m';
$str = '0706-F
0335-T
4113-O
8798-L
8798-L
0335B-T';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);