package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9-_\/]+`)
var str = `--------___________///////////////sdfsdf/sdfsdfsdfsdfsdf/sdfsdf___/--_`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}