re = /^[a-zA-Z0-9-_\/]+/m
str = '--------___________///////////////sdfsdf/sdfsdfsdfsdfsdf/sdfsdf___/--_'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end