package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^C[0-3][0-9][.][0-9]$`)
var str = `C00.0
C10.7
C29.9
C39.9
C40.0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}