$re = '/^C[0-3][0-9][.][0-9]$/m';
$str = 'C00.0
C10.7
C29.9
C39.9
C40.0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);