import re
regex = re.compile(r"\W*de\W+(\w+)\W+(\d{1,2}h\d{0,2})\W+à\W+(\w+)\W+(\d{1,2}h\d{0,2})\W*:\W*\+(\d+)(h|h00|:00|j)", flags=re.MULTILINE)
test_str = "de lundi 12h à mardi 13h30 : +12h,de dimanche 0h à lundi 6h30:+24h, de mardi 0h à mardi 23h : +2j"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")