import Foundation
let pattern = #"\W*de\W+(\w+)\W+(\d{1,2}h\d{0,2})\W+à\W+(\w+)\W+(\d{1,2}h\d{0,2})\W*:\W*\+(\d+)(h|h00|:00|j)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"de lundi 12h à mardi 13h30 : +12h,de dimanche 0h à lundi 6h30:+24h, de mardi 0h à mardi 23h : +2j"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
    var groups: [String] = []
    for rangeIndex in 1 ..< match.numberOfRanges {
        let nsRange = match.range(at: rangeIndex)
        guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
        let string = (testString as NSString).substring(with: nsRange)
        groups.append(string)
    }
    if !groups.isEmpty {
        result.append(groups)
    }
}
print(result)