const regex = /(?<name>\w+)\s*\(\K(?<e>[^()]*(?:\((?&e)\)[^()]*)*)(?=\))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<name>\\w+)\\s*\\(\\K(?<e>[^()]*(?:\\((?&e)\\)[^()]*)*)(?=\\))', 'gm')
const str = `foo(() ((hello) world))
bar (hello world!)
baz(ddd(()))
bazbaz(dsadsa")" dsada)
bazbaz(dsadsa")" d(()(das))das)das)ds)a(d(sa(d)()()sada); ;; d(ssss)
h(dsaqwd)
h(dsaqwd);h(dsaqwd)
h(dsaqwd); h(dsaqwd);
foo(() ((hello) world)); bar(gffjdk)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}