package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)https?://\S+`)
var str = `Пример 1: https://site.ru?get=1
Пример 2: https://сайт.рф?get=1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}