$re = '~https?://\S+~m';
$str = 'Пример 1: https://site.ru?get=1
Пример 2: https://сайт.рф?get=1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);