#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^[^.]*\.[^.]*\.\K"
Local $sString = "1.01.2" & @CRLF & _
"1.01.3" & @CRLF & _
"1.02.1"
Local $sSubst = "0"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)