import Foundation
let pattern = #"^[^.]*\.[^.]*\.\K"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
1.01.2
1.01.3
1.02.1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)