import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4}[a-zA-Z0-9]$";
final String string = "# CPT is a uniform coding system consisting of descriptive terms and identifying codes used primarily to identify medical services and procedures furnished by physicians and other health care professionals for which they bill public or private health insurance programs.\n"
+ "# It is a numeric coding system maintained by the American Medical Association (AMA).\n"
+ "# CPT codes can be subdivided into 3 levels/categories (not to be confused with HCPCS Level II!):\n"
+ "# - Category I: Evaluation & Management Services, Anesthesia, Surgery, Radiology, Procedures, Pathology & Laboratory Procedures, and Medicine Services & Procedures. All 5 characters are numeric.\n"
+ "# - Category II: Optional, but provide extra information about additional procedures typically performed with Category I CPT Codes, for example 3008F is “Body Mass Index (BMI) documented” which occurs during the Evaluation & Management Services. First 4 digits numeric, followed by an “F”.\n"
+ "# - Category III: Describe emergent or experimental services that help providers and government agencies track efficacy of those medical techniques. They may become Category I but have an expiration of 5 years. First 4 digits are numeric, followed by any other letter.\n"
+ "# This regex does *not* match codes with optional modifiers:-\n"
+ "# \"A medical coding modifier is two characters (letters or numbers) appended to a CPT® or HCPCS Level II code. The modifier provides additional information about the medical procedure, service, or supply involved without changing the meaning of the code. Medical coders use modifiers to tell the story of a particular encounter.\"\n"
+ "# (https://www.aapc.com/resources/what-are-medical-coding-modifiers)\n"
+ "# There is another pattern in regex101 that *does* match codes with optional modifiers\n\n"
+ "# Matched patterns (codes might not necessarily be genuine, in-dictionary codes! Regex simply matches the pattern)\n"
+ "33275\n"
+ "47360\n"
+ "3008F\n"
+ "0503F\n"
+ "1030F\n"
+ "6015F\n"
+ "0123T\n"
+ "0123t\n\n"
+ "# Does not match\n"
+ "0000\n"
+ "1\n"
+ "123456\n"
+ "123A\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}