import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(0|0[0-9]|[1-9][0-9]+)$";
final String string = "0\n"
+ "01\n"
+ "12v\n"
+ "2\n"
+ "9\n"
+ "01\n"
+ "15\n"
+ "36\n"
+ "090\n"
+ "108156790";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}