$re = '/^(0|0[0-9]|[1-9][0-9]+)$/m';
$str = '0
01
12v
2
9
01
15
36
090
108156790';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);