using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"panic(.go)?:";
string input = @"panic: a problem
goroutine 1 [running]:
main.main()
/.../panic.go:12 +0x47
...
exit status 2
TEST_should_panic
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}