import re
regex = re.compile(r"panic(.go)?:", flags=re.MULTILINE)
test_str = ("panic: a problem\n"
"goroutine 1 [running]:\n"
"main.main()\n"
" /.../panic.go:12 +0x47\n"
"...\n"
"exit status 2\n"
"TEST_should_panic\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")