re = /\b(?:(?:0[1-9]|1\d|2[0-8]|[1-9])-(?:0?2)-(?:\d+)|(?:0[1-9]|1\d|2\d|[1-9])-(?:0?2)-(?:(?:\d*?(?:(?:0[48]|[13579][26]|[2468][048])|(?:(?:[02468][048]|[13579][26])00))|[48]00|[48])(?=\D|\b))|(?:0[1-9]|1\d|2\d|30|[1-9])-(?:0?[469]|11)-(?:\d+)|(?:0[1-9]|1\d|2\d|3[01]|[1-9])-(?:0?[13578]|1[02])-(?:\d+))\b/m
str = '29-02-2016 - valid
29-02-2017 - invalid (not leap year)
30-03-2016 - valid
29-2-2017 - invalid (not leap year)
28-2-2017 - valid
2-2-2017 - valid
31-11-2017 - invalid (November has 30 days)
30-11-2017 - valid'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end