using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^P((?P<year>\d+)Y)?((?P<month>\d+)M)?((?P<day>\d+)D)?(T((?P<hour>\d+)H)?((?P<minute>\d+)M)?((?P<second>\d+)S)?)?$";
string input = @"P1Y2DT3H4M5S";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}