re = /^P((?P<year>\d+)Y)?((?P<month>\d+)M)?((?P<day>\d+)D)?(T((?P<hour>\d+)H)?((?P<minute>\d+)M)?((?P<second>\d+)S)?)?$/
str = 'P1Y2DT3H4M5S'
# Print the match result
str.match(re) do |match|
puts match.to_s
end