# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/REVIEWDOG_VERSION(?:\s*=\s*|:?\s*)[\"|\']?v?\K\d+\.\d+(\.\d+)?(-[^\'\"\s]*)?/1.0.0-nightly23423423423423523gdsg/gm;t' <<< "This is test file.
REVIEWDOG_VERSION=v0.1.0
REVIEWDOG_VERSION = v0.1.0
REVIEWDOG_VERSION=0.1.0
REVIEWDOG_VERSION = 0.1.0
REVIEWDOG_VERSION=\"v0.1.0\"
REVIEWDOG_VERSION='v0.1.0'
REVIEWDOG_VERSION = \"v0.1.0\"
REVIEWDOG_VERSION = 'v0.1.0'
REVIEWDOG_VERSION=\"0.1.0\"
REVIEWDOG_VERSION='0.1.0'
REVIEWDOG_VERSION = \"0.1.0\"
REVIEWDOG_VERSION = '0.1.0'
REVIEWDOG_VERSION=\"v0.1.0-nightly20201208+12faa31\"
REVIEWDOG_VERSION='v0.1.0-nightly20201208+12faa31'
REVIEWDOG_VERSION = \"v0.1.0-nightly20201208+12faa31\"
REVIEWDOG_VERSION = 'v0.1.0-nightly20201208+12faa31'
REVIEWDOG_VERSION=\"0.1.0-nightly20201208+12faa31\"
REVIEWDOG_VERSION='0.1.0-nightly20201208+12faa31'
REVIEWDOG_VERSION = \"0.1.0-nightly20201208+12faa31\"
REVIEWDOG_VERSION = '0.1.0-nightly20201208+12faa31'
ENV REVIEWDOG_VERSION=0.1.0
ENV REVIEWDOG_VERSION 0.1.0
ARG REVIEWDOG_VERSION=0.1.0
yaml:
REVIEWDOG_VERSION: 0.1.0
REVIEWDOG_VERSION: \"0.1.0\"
REVIEWDOG_VERSION: '0.1.0'
The above version should be updated to the latest version with this action.
Other test cases.
REDPEN_VERSION=1.10.1
TMUX_VERSION=3.0
"